If you see the error 'Please Login to use Chat'
  • 2 Minutes to read
  • Dark
    Light

If you see the error 'Please Login to use Chat'

  • Dark
    Light

NOTE
For AtomChat to load successfully, your website should be secure, i.e have an SSL certificate. Even if you are accessing it via an IP or Localhost, please ensure it opens as "https://.."


.      


AtomChat gives you the option to allow your non-logged-in website visitors (we call them Guest users) to access chat. 

First, please check this setting 

  1. Login to your AtomChat Admin Panel 
  2. Go to Settings Authentication Would you like Guests to Login as well?
  3. Set this to Yes if you want Guests to chat and No if you only want logged-in users to chat.

If Guest chat is disabled, a non-logged-in user will see the 'Please login to use chat on your website's login page. This is expected behavior. To hide this:

  1. Login to your AtomChat Admin Panel→ Settings → Editor
     
  2. 2. Select the Custom CSS option from the dropdown and add the following code

#cometchat_hidden {
	display: none !important;
}

   3. Enable Custom CSS using the radio button and hit Save

If you see the 'Please login to use Chat' error and you are logged in, please check for the following

If you are a WordPress User

You have entered incorrect API key and Auth Key Values

  1. Login to your WordPress Admin Dashboard → AtomChat Plugin → Authentication Settings

  2. Now open your AtomChat Admin Panel → Settings → API Key

  3. Please check and ensure the Keys are correctly added AtomChat’s Authentication settings on WordPress

NOTE
This applies to both WordPress and Non-WordPress users. Please check the API Key and Auth Key Values 
in the code for your integration.

You have signed up for a new account

If you used AtomChat before and signed up once again for the same website

  1. De-activate and delete the existing AtomChat Plugin

  2. Re-install AtomChat and use your current subscription’s License Key

  3. Add the Auth key and API key values of the current subscription from your  AtomChat Admin Panel

If you are a Non-WordPress User

Chat integration variables are not correctly configured

  1. Open the page on your website where you see the error and Inspect the page or press F12

  2. Open Console, type chat_id, and hit enter

  3. Check if there is a value assigned to chat_id, it should have a non-zero value

  4. If not, please check your chat variable configuration or write to us for help at support@atomchat.com

For both WordPress and Non-WordPress Users

You have disabled AtomChat for some user roles

  1. Login to your AtomChat Admin Panel → Settings → Role Based Access

  2.  If you are login as a user with role ‘A’, select that role from the list

  3. Check the option 'Disable AtomChat completely for this Role' and make sure it is not selected 

If you still need help

Please feel free to reach out or schedule an integration meeting with our engineering team.

Happy to help :)


Was this article helpful?